Uploaded image for project: 'Appcelerator CLI'
  1. Appcelerator CLI
  2. CLI-1280

CLI: Cannot create projects when using 7.0.0-master.11

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: Release 7.0.0
    • Fix Version/s: CLI Release 7.0.0
    • Component/s: CLI
    • Labels:
    • Environment:

      CLI 7.0.0-master.11
      Node v8.8.1
      NPM 5.4.2

    • Severity:
      Blocker
    • Story Points:
      0
    • Sprint:
      2017 Sprint 23 Tooling

      Description

      When using CLI 7.0.0-master.11, I am unable to create a new project. I get the below error:

      ? What's your application id (example: com.myapp)? com.appc.appid
      An uncaught exception was thrown!
      "listener" argument must be a function
      "listener" argument must be a function
      

      Steps to reproduce issue
      1. Create a new project with appc new
      2. Enter valid project information

      Expected Results
      The project is created successfully

      Actual Results
      Project creation fails with the above error after entering the app id

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                emerriman Eric Merriman
                Reporter:
                ewieber Eric Wieber
              • Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Git Source Code