Uploaded image for project: 'Appcelerator CLI'
  1. Appcelerator CLI
  2. CLI-1266

async function without callback warning when downloading hyperloop

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Low
    • Resolution: Fixed
    • Affects Version/s: CLI Release 6.2.4
    • Fix Version/s: CLI Release 7.0.0
    • Component/s: None
    • Labels:
      None
    • Environment:

      Node 8.5.0
      appc cli 6.2.4
      appc npm 4.2.9

    • Severity:
      Minor
    • Story Points:
      1
    • Sprint:
      2017 Sprint 19 Tooling

      Description

      Description

      Running appc with node 8.5.0 will emit a deprecation warning, tried to get the stack trace but nodes --trace-deprecation flag isn't getting passed down through all the subprocessing I think, based off the timing though pretty sure it's here https://github.com/appcelerator/appc-cli-titanium/blob/e39aed61b04d62508d26b93af57a8dd73869b5ee/plugins/util.js#L626

      2017-09-20T10:43:59.040Z | INFO   | Finished Downloading & Installing hyperloop
      (node:11307) [DEP0013] DeprecationWarning: Calling an asynchronous function without callback is deprecated.
      

      Steps to reproduce
      1. Install node 8.5.0
      2. Remove latest hyperloop module and plugin
      3. Set lastUpdateCheckTiDownloads in appc-cli.json to null
      4. Run a build
      Actual

      Deprecation warning

      Expected

      No deprecation warning

        Attachments

          Activity

            People

            • Assignee:
              eharris Ewan Harris
              Reporter:
              eharris Ewan Harris
              Reviewer:
              Feon Sua Xin Miao
            • Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Git Source Code