Uploaded image for project: 'Appcelerator CLI'
  1. Appcelerator CLI
  2. CLI-1115

Set Node 4.x as minimum supported version

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: Release 6.0.0
    • Fix Version/s: Release 6.0.0
    • Component/s: Core
    • Labels:
    • Environment:

      OS: Mac OS X 10.11.6
      Appc core: 6.0.0-47
      Appc NPM: 4.2.8-6

    • Story Points:
      2
    • Sprint:
      2016 Sprint 20 Tooling

      Description

      Description

      In 6.0.0/4.8.0 it's planned to move to 4.X as the minimum supported version. This is implemented in the SDK/Titanium and in TISTUD but there is no implementation for this in the CLI. It seems to me like we should want to restrict the version in the CLI also and maybe introduce something similar to Titanium i.e warnings for node versions higher than a certain version etc

      Steps to reproduce
      1. Set node 0.12.7 as your selected node version using your favourite node version manager or the official installer
      2. Download a 6.0.0 CLI, appc use 6.0.0-47
      3. Use the CLI for non titanium tasks (as Titanium has this already implemented)
      Actual result

      The appc cli is perfectly happy with you using 0.12.7

      Expected result

      As we are moving to a minimum of 4.X for every other product. So should the CLI

        Attachments

          Activity

            People

            • Assignee:
              fmiao Feon Sua Xin Miao
              Reporter:
              eharris Ewan Harris
              Reviewer:
              Chee Kiat Ng (Inactive)
            • Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Git Source Code