Uploaded image for project: 'Appcelerator CLI'
  1. Appcelerator CLI
  2. CLI-1077

CLI outputting non-JSON warning to Studio

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: Release 5.4.0
    • Fix Version/s: Release 6.0.0
    • Component/s: Titanium
    • Labels:
      None
    • Story Points:
      3
    • Sprint:
      2016 Sprint 18 Tooling

      Description

      While doing some Studio work, I saw that the CLI is spitting out warning text in it;s output, when it's being invoked by Studio (presumably with some command asking for JSON output). Since the warning test is not JSON, Studio's parsing breaks:

      You are attempting to run appc 5.4.0 which was compiled for node v5.12.0 but you are now running node v5.10.0
      Rebuilding package modules ...
      Package modules rebuilt!
       
      {
      	"activeSDK": "6.0.0.v20160811221444",
      	"defaultInstallLocation": "/Users/cwilliams/Library/Application Support/Titanium",
      	"installLocations": [
      		"/Users/cwilliams/Library/Application Support/Titanium",
      		"/Library/Application Support/Titanium"
      	],
      	"installed": {
      // rest of JSON snipped ...
      

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                fmiao Feon Sua Xin Miao
                Reporter:
                cwilliams Christopher Williams
                Reviewer:
                Kondal Kolipaka (Inactive)
              • Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Git Source Code