Uploaded image for project: 'Appcelerator CLI'
  1. Appcelerator CLI
  2. CLI-1070

If you use node 0.12.X, then you'll be unable to download the Hyperloop module through 'appc new'

    Details

    • Sprint:
      2016 Sprint 17 Tooling

      Description

      I'm unable to create new projects with the option Would you like to enable Hyperloop for this app (This may take a while...)? activated.

      When the CLI tries to download the new version of the hyperloop module (1.2.5) it retrieves the warn message:
      2016-08-04T23:52:23.500Z | WARN | Failed to enable Hyperloop: Error: TypeError: undefined is not a function

      Steps To Reproduce:
      1. Create a new project with `appc new`.
      2. Fill in all the necessary details.
      3. Select Yes on the option Would you like to enable Hyperloop for this app (This may take a while...)?

      Actual Results:
      The project is created without the hyperloop module and it's not possible to run hyperloop-projects.

      Expected Result:
      Appcelerator CLI should find the latest version of hyperloop module and put it in the right folder

        Attachments

          Activity

            People

            • Assignee:
              fmiao Feon Sua Xin Miao
              Reporter:
              xicovarisco_orange Francisco Ruaro Varisco
              Reviewer:
              Chee Kiat Ng (Inactive)
            • Watchers:
              8 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Git Integration