Uploaded image for project: 'Appcelerator CLI'
  1. Appcelerator CLI
  2. CLI-1066

Hyperloop: If you have an older version of Hyperloop in your module global space, you cannot get the newer Hyperloop version

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: Release 5.4.0
    • Component/s: Core
    • Labels:
    • Environment:

      Appc CLI NPM: 4.2.7
      Appc CLI Core: 5.4.0-37
      Arrow: 1.8.2
      SDK: 5.4.0.v20160802165655
      Node: v4.4.7
      OS: Mac OS X (10.11.6), Windows 10

    • Severity:
      Major
    • Story Points:
      5
    • Sprint:
      2016 Sprint 16 Tooling

      Description

      Details: If you have an older version of Hyperloop in your module global space, you cannot get the newer Hyperloop version.

      Notes: To workaround this issue, you will need to remove both (Android and iOS) Hyperloop modules from the global space.

      Steps to reproduce:

      1. In your global module space, ~/Library/Application Support/Titanium/modules or C:\ProgramData\Titanium\modules, rename your Hyperloop module version to an older version e.g. modules/android/hyperloop/1.2.5 -> modules/android/hyperloop/1.2.4.
      2. On Mac, you should remove modules/iphone/hyperloop/<ver> folder.
      3. Get the latest Hyperloop module via appc new; go through all the prompts
      4. Check your module global space again

      Actual: The latest Hyperloop module is not downloaded.
      Expected: The newest Hyperloop module should be downloaded if you have an older version of it.

        Attachments

          Activity

            People

            • Assignee:
              fmiao Feon Sua Xin Miao
              Reporter:
              wluu Wilson Luu (Inactive)
              Reviewer:
              Chee Kiat Ng (Inactive)
            • Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Backbone Issue Sync

                • It looks like Backbone Issue Sync is not enabled for your project.

                  Git Source Code