Uploaded image for project: 'Appcelerator CLI'
  1. Appcelerator CLI
  2. CLI-1063

Rebuilds package modules every time I run a command

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Critical
    • Resolution: Cannot Reproduce
    • Affects Version/s: Release 5.3.1
    • Fix Version/s: None
    • Component/s: Core
    • Labels:
      None
    • Severity:
      Major
    • Sprint:
      2017 Sprint 09 Tooling

      Description

      Every time I try to run an appc command, I get the same warning output about using No v6.x, but modules were built with Node v5.10.0. It then proceeds to recompile the package modules.

      Appcelerator_Studio_Workspace|⇒ appc login
       
      You are attempting to run appc 5.3.1 which was compiled for node v5.10.0 but you are now running node v6.2.2
      Rebuilding package modules ...
      

      I'd expect this to happen once, not again and again every time I run a command (using the same Node version).

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                cwilliams Christopher Williams
              • Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Git Source Code