Uploaded image for project: 'Appcelerator CLI'
  1. Appcelerator CLI
  2. CLI-1055

Node version warning from SDK is not shown

    Details

    • Type: Story
    • Status: Open
    • Priority: Low
    • Resolution: Unresolved
    • Affects Version/s: Release 5.4.0
    • Fix Version/s: None
    • Component/s: Core, Titanium
    • Environment:

      Windows 10
      Appc CLI Core: 5.4.0-35
      Appc CLI NPM: 4.2.7
      Ti SDK: 5.4.0.v20160725003348
      Appc Studio: 4.7.0.201607130543

      Description

      Description

      When building a project using a 5.4.X SDK with ti cli and node 6 it will log the following warning

      [WARN]  Support for Node.js v6.2.1 has not been verified for Titanium SDK 6.0.0.v20160725113651
      [WARN]  If you run into issues, try downgrading to Node.js v5
      

      However when building using appc cli this warning will not be shown to the user

      Steps to reproduce
      1. Install node 6 using your preferred method
      2. Build a titanium project using a 5.4.X SDK
      Actual result

      You should see the warning above

      Expected result

      There is no warning

        Attachments

          Activity

            People

            • Assignee:
              jvennemann Jan Vennemann
              Reporter:
              eharris Ewan Harris
            • Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:

                Git Source Code