Uploaded image for project: 'Appcelerator CLI'
  1. Appcelerator CLI
  2. CLI-1046

Getting the correct module versions from dashboard

    Details

    • Story Points:
      5
    • Sprint:
      2016 Sprint 16 Tooling

      Description

      When Ti SDK 6.0.0 is released, we'll be support a new version of android v8. And because of that, all titanium modules have to be recompiled to support it, and it's not backward compatible.
      i.e. ti.facebook v3.X.X works for ti.sdk 6 and newer vs ti.facebook v2.X.X works for ti sdk 5.4.0 and older.

      Therefore, the following modules:
      Hyperloop, ACA, APM that are downloaded automatically with CLI, has to be smart enough to be able to obtain the right versions when doing appc run or appc new. Its ok to have both versions co-exist in the local machine. And it's also ok that we can't control the developer if he chooses to use a 5.4.0 module on a 6.0.0 project.

      Dashboard has recommended that the payload can be expanded to provide different urls for both versions. This will be a cross-team effort.

        Attachments

          Activity

            People

            • Assignee:
              fmiao Feon Sua Xin Miao
              Reporter:
              cng Chee Kiat Ng (Inactive)
              Reviewer:
              Chee Kiat Ng (Inactive)
            • Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Git Source Code