Uploaded image for project: 'Aptana Studio'
  1. Aptana Studio
  2. APSTUD-8194

Studio 3.5.1 Toolbar: odd delay after virtual desktop switch

    Details

    • Type: Bug
    • Status: Open
    • Priority: Low
    • Resolution: Unresolved
    • Affects Version/s: Aptana Studio 3.5.0
    • Fix Version/s: None
    • Component/s: Performance, Usability
    • Labels:

      Description

      I use the virtual desktop manager Dexpot (http://www.dexpot.de/) which allows me to switch between several desktops on a Windows machine (Windows 7 Pro x64).

      After installing Aptana Studio 3.5.1 (build 3.5.1.201404101117), I see an odd display behavior. If the Studio window has been hidden (that is, when I switch to another virtual desktop), when it re-displays the toolbars (below the menu but above the Editor, Project Explorer, etc. views, and on the sides) are not displayed immediately, but pop into existence after a second or two. Everything functions as expected after the toolbars appear, but it's disconcerting.

      This did not happen with Aptana Studio 3.4.2, but began happening immediately when I installed Studio 3.5.1.

      Right after restoring the desktop containing Aptana Studio it looks like the attached screenshot aptana_toolbar_delay_1.jpg.

      After a couple of seconds it looks like the attached screenshot aptana_toolbar_delay_2.jpg.

      This is with the new "Light Studio" theme. I tried some of the other themes and saw similar behavior.

        Attachments

          Activity

            People

            • Assignee:
              cwilliams Christopher Williams
              Reporter:
              ddirks87 Douglas Dirks
            • Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:

                Git Integration