Aptana Studio
  1. Aptana Studio
  2. APSTUD-7664

Rename - Refactor hotkey inserts registered trademark symbol

    Details

    • Type: Bug Bug
    • Status: Open
    • Priority: None None
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: Backlog
    • Component/s: PyDev
    • Labels:
    • Environment:

      Description

      Previously, using the ALT+COMMAND+R key combination after highlighting a variable name in a Java file would go into the rename refactor mode. Now, the key combination replaces the highlighted text with a registered trademark symbol. How can I get the key combination to go into the rename refactor mode instead of inserting the symbol?

      The only recent change I can remember making is installing PyDev a few weeks ago. With the default PyDev installed, ALT+COMMAND+R opens a context menu in the lower right corner with 2 option: rename and set next symbol (this is in addition to replace the text with the symbol). I disabled the Set Next Symbol key binding in my preferences, restarted eclipse, and tried the key combo again. The text was still replaced by the symbol but the rename refactor mode was not entered did not open. I uninstalled PyDev, restarted eclipse, and tried the key combo again. The text was still replaced by the symbol.

      I have created questions on [stackoverflow][] and [eclipse community forums][] which have shown a few other users with a similar experience.

      [stackoverflow]: http://stackoverflow.com/questions/13750847/eclipse-rename-refactor-hotkey-inserts-registered-trademark-symbol
      [eclipse community forums]: http://www.eclipse.org/forums/index.php?t=rview&goto=990973

        Activity

        Hide
        Matt Burke added a comment - - edited

        A workaround has been posted on stack overflow by Ed Baskerville that worked for me.

        Show
        Matt Burke added a comment - - edited A workaround has been posted on stack overflow by Ed Baskerville that worked for me.

          People

          • Assignee:
            Fabio Zadrozny
            Reporter:
            Matt Burke
          • Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:

              Development