Uploaded image for project: 'Aptana Studio'
  1. Aptana Studio
  2. APSTUD-7619

Aptana 64 bit version crashes on startup on 64bit Linux OS with 64bit Oracle 7 java

    Details

    • Type: Bug
    • Status: Closed
    • Priority: High
    • Resolution: Fixed
    • Affects Version/s: Aptana Studio 3.3.0
    • Fix Version/s: Aptana Studio 3.3.1
    • Component/s: Build
    • Labels:
    • Environment:

      Description

      It looks like the 64 bit version available for download is somehow the 32bit version

      Downloaded http://download.aptana.com/studio3/standalone/3.3.0/linux/Aptana_Studio_3_Setup_Linux_x86_64_3.3.0.zip

      Extracted as root to /opt and tried to run as unprivileged user, error:

      JVM terminated. Exit code=13
      /usr/bin/java
      -Xms40m
      -Xmx512m
      -Declipse.p2.unsignedPolicy=allow
      -Declipse.log.size.max=10000
      -Declipse.log.backup.max=5
      -Djava.awt.headless=true
      -XX:MaxPermSize=256m
      -jar /opt/softjury/apps/Aptana_Studio3.3//plugins/org.eclipse.equinox.launcher_1.2.0.v20110502.jar
      -os linux
      -ws gtk
      -arch x86
      -showsplash
      -launcher /opt/softjury/apps/Aptana_Studio3.3/AptanaStudio3
      -name Aptana Studio 3
      --launcher.library /opt/softjury/apps/Aptana_Studio3.3//plugins/org.eclipse.equinox.launcher.gtk.linux.x86_1.1.100.v20110505/eclipse_1407.so
      -startup /opt/softjury/apps/Aptana_Studio3.3//plugins/org.eclipse.equinox.launcher_1.2.0.v20110502.jar
      --launcher.overrideVmargs
      -exitdata 550023
      -vm /usr/bin/java
      -vmargs
      -Xms40m
      -Xmx512m
      -Declipse.p2.unsignedPolicy=allow
      -Declipse.log.size.max=10000
      -Declipse.log.backup.max=5
      -Djava.awt.headless=true
      -XX:MaxPermSize=256m
      -jar /opt/softjury/apps/Aptana_Studio3.3//plugins/org.eclipse.equinox.launcher_1.2.0.v20110502.jar

      Version 3.2.2 works without problems, so i looked for differences:

      % grep launcher.gtk Aptana_Studio*/*.ini
      Aptana_Studio.3.2.2/AptanaStudio3.ini:plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1.100.v20110505
      Aptana_Studio.3.3.0/AptanaStudio3.ini:plugins/org.eclipse.equinox.launcher.gtk.linux.x86_1.1.100.v20110505

      % file Aptana_Studio*/plugins/org.eclipse.equinox.launcher.gtk.linux./.so
      Aptana_Studio.3.2.2/plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1.100.v20110505/eclipse_1407.so: ELF 64-bit LSB shared object, x86-64, version 1 (SYSV), dynamically linked, not stripped
      Aptana_Studio.3.3.0/plugins/org.eclipse.equinox.launcher.gtk.linux.x86_1.1.100.v20110505/eclipse_1407.so: ELF 32-bit LSB shared object, Intel 80386, version 1 (SYSV), dynamically linked, not stripped

      % file Aptana_Studio*/AptanaStudio3
      Aptana_Studio.3.2.2/AptanaStudio3: ELF 64-bit LSB executable, x86-64, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.4.0, not stripped
      Aptana_Studio.3.3.0/AptanaStudio3: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.2.5, not stripped

      Any suggestions?

        Issue Links

          Activity

          thermoman Marcel added a comment -

          It seems someone mislabeled the zip archives and switched 32bit with 64bit and vice versa, see APSTUD-7620

          mxia Michael Xia added a comment -

          Could you try the latest stable release (3.3.1) to see if the problem is resolved?

          Thanks.

          cheadley Clayton Headley added a comment -

          Verified Aptana 3.3.1 zip files contain the correct versions. Closing ticket.

          If this is still an issue for you using the 3.3.1 release please comment and we will reopen this ticket.


            People

            • Assignee:
              mxia Michael Xia
              Reporter:
              thermoman Marcel
            • Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development

                  Poker Sessions

                  This issue is currently not assigned to any Poker Session.