Uploaded image for project: 'Aptana Studio'
  1. Aptana Studio
  2. APSTUD-7498

Error install Eclipse plugin with OEPE

    Details

      Description

      When you have OEPE (Oracle Enterprise Pack for Eclipse) installed in your Eclipse Juno (v.4.2), there is a conflict when you try to install Apatana Studio 3 Plugin.

      There is now to install this plugin via MarketPlace (see screenshot) and via the Update Site to install a "new software" there is this error :

      Cannot complete the install because of a conflicting dependency.
      Software being installed: Aptana Studio 3 Plugin 3.2.2.201208200959-7C7C37EAEI9YFMKNDc1bIClwcOi- (com.aptana.feature.studio.feature.group 3.2.2.201208200959-7C7C37EAEI9YFMKNDc1bIClwcOi-)
      Software currently installed: Oracle Enterprise Pack for Eclipse 2.1.0.201207241647 (oracle.eclipse.tools.juno.oepe.product.feature.group 2.1.0.201207241647)
      Only one of the following can be installed at once:
      Core Plug-in 2.5.0.2012040618 (org.python.pydev.core 2.5.0.2012040618)
      Core Plug-in 2.7.0.2012080220 (org.python.pydev.core 2.7.0.2012080220)
      Cannot satisfy dependency:
      From: Aptana Studio 3 Plugin 3.2.2.201208200959-7C7C37EAEI9YFMKNDc1bIClwcOi- (com.aptana.feature.studio.feature.group 3.2.2.201208200959-7C7C37EAEI9YFMKNDc1bIClwcOi-)
      To: com.aptana.pydev.feature.feature.group [2.7.0.2012080220-7a8y-87Zr6am_76Z]
      Cannot satisfy dependency:
      From: Aptana Pydev 2.7.0.2012080220-7a8y-87Zr6am_76Z (com.aptana.pydev.feature.feature.group 2.7.0.2012080220-7a8y-87Zr6am_76Z)
      To: org.python.pydev.core [2.7.0.2012080220]
      Cannot satisfy dependency:
      From: Oracle Enterprise Pack for Eclipse 2.1.0.201207241647 (oracle.eclipse.tools.juno.oepe.product.feature.group 2.1.0.201207241647)
      To: oracle.eclipse.tools.juno.weblogic.scripting.feature.group [2.1.0.201207241647]
      Cannot satisfy dependency:
      From: Oracle WebLogic Scripting Tools 2.1.0.201207241647 (oracle.eclipse.tools.juno.weblogic.scripting.feature.group 2.1.0.201207241647)
      To: oracle.eclipse.tools.weblogic.scripting [5.1.0.201207241647]
      Cannot satisfy dependency:
      From: Oracle WebLogic Scripting Tools 5.1.0.201207241647 (oracle.eclipse.tools.weblogic.scripting 5.1.0.201207241647)
      To: bundle org.python.pydev.core [2.5.0,2.6.0)

        Attachments

          Activity

            People

            • Assignee:
              pinnamuri Praveen Innamuri (Inactive)
              Reporter:
              bendwe Benjamin Dewez
            • Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:

                Git Integration