Uploaded image for project: 'Aptana Studio'
  1. Aptana Studio
  2. APSTUD-7243

eclipse with pydev deleted .py files after debugging

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Medium
    • Resolution: Cannot Reproduce
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: PyDev
    • Labels:
      None
    • Environment:

      Windows x64, pydev 2.5.0.2012040618, eclipse Version: 3.7.2 Build id: M20120208-0800

      Description

      Happened once to me, and once to another user:
      http://stackoverflow.com/questions/11372596/eclipse-juno-with-pydev-deletes-my-django-files

      While using eclipse and pydev in the debug view, the debug session script being executed threw an exception and the interpreter terminated. On termination, two open editor windows prompted that the files were changed on disc. I chose to refresh. The files weren't just changed, the files were deleted from disc. The files were not able to be recovered using the 'Restore from local history...' right-click option in the file view.

      I can't reproduce this yet.

      1. eclipse_about.txt
        493 kB
        Erik Michael Purins

        Activity

        epu Erik Michael Purins added a comment -

        Here are the eclipse details.

        epu Erik Michael Purins added a comment -

        Please resolve as Cannot Reproduce, I can't get this to happen again.


          People

          • Assignee:
            fzadrozny Fabio Zadrozny
            Reporter:
            epu Erik Michael Purins
          • Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development

                Poker Sessions

                This issue is currently not assigned to any Poker Session.