Uploaded image for project: 'Aptana Studio'
  1. Aptana Studio
  2. APSTUD-4976

FTP Remote do not show files/folders when disconnected AND reconnected

    Details

    • Type: Bug
    • Status: Open
    • Priority: Low
    • Resolution: Unresolved
    • Affects Version/s: Aptana Studio 3.2.0
    • Fix Version/s: None
    • Labels:
    • Environment:

      In Aptana Studio 3, build: 3.2.0.201206251729
      Operating System is: Windows Seven 64bit, 6GB RAM (french)

    • Story Points:
      8

      Description

      As example:

      I have added an FTP connection through the tab 'Remote' and clicking the little icon 'Add new FTP Site ...'

      Type: FTP (not sftp AND not anonymous).

      SO .. now,

      I then clicked on the new FTP connection displayed with the right button and I select 'Transfer Files ...' and the transfer window is displayed correctly the content of the distant FTP folder.

      In the console I have this:

      ---------- FTP my.domain.net ----------
      220 ProFTPD 1.3.1rc2 Server ready.
      ftp> USER u_test
      331 Password required for u_test
      ftp> PASS ********
      230 Bienvenue u_test
      ftp> PWD
      257 "/" is the current directory
      ftp> CWD www/dev/v1
      250 CWD command successful
      ftp> TYPE I
      200 Type set to I
      ftp> FEAT
      211-Features:
       LANG en
       MDTM
       UTF8
       REST STREAM
       SIZE
      211 End
      ftp> SITE HELP
      214-The following SITE commands are recognized (* =>'s unimplemented)
       The following SITE extensions are recognized:
       RATIO -- show all ratios in effect
       HELP
       CHGRP
       CHMOD
      214 Direct comments to root@my.domain.net
      ftp> SYST
      215 UNIX Type: L8
      ftp> STAT /
      211-Status of /:
       drwx-----x   5 u_test     users        4096 Dec 17  2010 .
       drwx-----x   5 u_test     users        4096 Dec 17  2010 ..
       -rwx---r-x   1 u_test     users         127 Dec 17  2010 .bash_logout
       -rwx---r-x   1 u_test     users         193 Dec 17  2010 .bash_profile
       -rwx---r-x   1 u_test     users         551 Dec 17  2010 .bashrc
       drwx---r-x   2 u_test     users        4096 Dec 17  2010 .ssh
       drwx---r-x   2 u_test     users        4096 Dec 17  2010 cgi-bin
       drwx---r-x   6 u_test     users        4096 Jun 29 13:16 www
      211 End of status
      ftp> CWD /
      250 CWD command successful
      ftp> STAT www/dev/v1/
      211-Status of www/dev/v1/:
       
       and all files are listed without any problems..
      

      NOW..

      I close the new tab opened (which is the Transfer tab).

      Now, without disconnect me from the current connection to the FTP Site, I try to reopen the Transfer Files tab by clicking right on the FTP connection and I select 'Transfer Files ...' and the transfer window is displayed correctly the content of the distant FTP folder.

      Always without disconnect me from the current connection, in 'Remote' tab, if I click on '[+]' icon, I can list all the content of choosen FTP folder just in 'Remote' tab.

      BUT...

      IF:

      I disconnect, and reconnect me from the current FTP connection to that FTP Site..

      Console write:

      ftp> QUIT
      221 Goodbye.
      

      And now, if I try to reopen the Transfer Files tab by clicking right on the FTP connection and I select 'Transfer Files ...' and the transfer window is displayed nothing.. Just quickly 'Pending..' and.. no more after it disappear.

      In 'Remote' tab, if I click on '[+]' icon, I cannot see any of my ftp content, just, as the same case explained a bit of up: Just quickly 'Pending..' and.. no more after it disappear.

      In Console, the logged action is:

      ---------- RECONNECTING - FTP my.domain.net ----------
      220 ProFTPD 1.3.1rc2 Server ready.
      ftp> USER u_test
      331 Password required for u_test
      ftp> PASS ********
      230 Bienvenue u_test
      ftp> PWD
      257 "/" is the current directory
      ftp> CWD www/dev/v1
      250 CWD command successful
      ftp> TYPE I
      200 Type set to I
      ftp> STAT www/dev/v1/
      450 www/dev/v1/: No such file or directory
      

      As you can see, it seems it cannot find my ftp content (and I can tell you just after, I reconnect to the FTP Site with FileZilla and i can see my ftp content in FileZilla.., so it is a bug from Aptana Studio).

      And for resolving the problem, all I can do is restarting (close:relaunch) Aptana Studio.

      But, same problems happened again and again, if I disconnect just 1 time from FTP Site.

      Can you fix that? (Or tell me how and WHY it is happened?)

        Attachments

          Activity

            People

            • Assignee:
              pinnamuri Praveen Innamuri (Inactive)
              Reporter:
              chrisaph Christophe Klug
            • Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:

                Git Integration