Uploaded image for project: 'Aptana Studio'
  1. Aptana Studio
  2. APSTUD-4699

Aptana forces the path of the Document root on server to start with a "/" (slash)

    Details

    • Story Points:
      5

      Description

      There is some problem in Window platform, it cause unable to start php debug.
      I use PDT with xDebug few year and no problem at all, but move to aptana, it not work.

      Version :
      Aptana studio 3 nightly
      Windows 7 32bit pro
      PHP 5.2.6
      Apache 2.2.9
      xDebug 2.1.2-5.2-vc6-nts.dll

      Problem:
      All problem come from the web servers setting

      -Preferences -> Aptana Studio -> Web Server -> simple web server or external web server (both of them have this bugs.)

      On the Document Root , if i select my web root and press [OK]
      Aptana automatic add a slash to the path, if i remove manully and press [OK], aptana will add it again forever.

      See screen shot:

      This cause not able to start the url after i press Debug button,
      Aptana will translate the url to
      [LocalPath] + [HTTP Url]

      see screenshot:

      This's not happen on ubuntu OS, only on windows OS.bugs

        Attachments

          Activity

            People

            • Assignee:
              cwilliams Christopher Williams
              Reporter:
              alex8974fs asdd33
            • Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Git Integration