Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Medium Medium
    • Resolution: Fixed
    • Affects Version/s: Aptana Studio 3.1.1
    • Component/s: source-control
    • Labels:
      None
    • Environment:
    • Story Points:
      8

      Description

      After updating to version 3.1.1.201204131931, Git doesn't recognize file changes anymore and commit option stays disabled. Also there are no asterisk character next to file name. Restarting Aptana helps so that changed files are now marked with asterisk and commit is enabled, but again new changes are ignored.

        Issue Links

          Activity

          Chris Williams added a comment -

          After a little research reproducing this: This doesn't happen on Mac, and on Windows the IDE is picking up the file events from outside the IDE - but the git support is not properly "reacting" to them. My guess is that the listener that forces refreshes of the git status on changes is breaking due to some path issue (we take the path of the changed file, then try to find the corresponding file from a relative path in the git repo, and then update our git status for it if it's under the repo - it's probably not generating that relative path properly).

          Chris Williams added a comment -

          Found I was using improper implementations of generating repo relative paths in a couple locations, rather than using the correct one available in GitRepository.repoRelativePath(). Replacing them with calls to that should fix this issue for Windows users.

          Chris Williams added a comment -

          For QA to verify:

          1. This must be verified on a Windows machine!
          2. Create a new Web project
          3. Right click on it and choose Team > Share Project... Select the entry for it ont he dialog's table, click the Create button, then click through to Finish.
          4. Then open a Terminal view to the root of the project's location on disk.
          5. Run "touch newfile.txt"
          6. After a slight delay the "newfile.txt" file should appear in the Project/App Explorer and it should be shown with a dirty marker next to it's name and typically have a red bg color (to denote an unstaged change).
          Shalom Gibly added a comment -

          Verified the fix on Windows 7 64bit
          Titanium Studio, build: 2.0.2.201204201120

          Ingo Muschenetz added a comment -

          Updated component


            People

            • Assignee:
              Chris Williams
              Reporter:
              Teemu Turkia
            • Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development