Details

      Description

      Hi,
      a few days ago the stable version of PHP 5.4 was released. If would be great if Aptana would support the new features like the new short array syntax or traits. Currently Aptana says the code is invalid at this point.

      Thanks and greetings
      Leo

      1. 5-4.php
        1 kB
        Leo Unglaub
      1. _1334366357925.png
        42 kB

        Issue Links

          Issues in Epic

          There are no issues in this epic.

            Activity

            Hide
            Kirk Olson added a comment -

            I have Aptana Studio 3 Plugin 3.5.0.201309112453 installed.

            When I switch "PHP Version" in my project properties to "PHP 5.4.x" I have the correct PHP 5.4 code-assist for a little while. However this setting automagically switches back to "PHP 5.3.x" for some reason, giving me error messages for [...] and traits once again.

            Anyone?

            Show
            Kirk Olson added a comment - I have Aptana Studio 3 Plugin 3.5.0.201309112453 installed. When I switch "PHP Version" in my project properties to "PHP 5.4.x" I have the correct PHP 5.4 code-assist for a little while. However this setting automagically switches back to "PHP 5.3.x" for some reason, giving me error messages for [...] and traits once again. Anyone?
            Hide
            Dennis Tap added a comment - - edited

            I have the same problem as Kirk, switching to PHP 5.4.x but is set to PHP 5.3.x when I return to check the setting because trait errors.

            Did someone found a reason/ solution?

            Show
            Dennis Tap added a comment - - edited I have the same problem as Kirk, switching to PHP 5.4.x but is set to PHP 5.3.x when I return to check the setting because trait errors. Did someone found a reason/ solution?
            Hide
            Michael Ruoss added a comment -

            Me, too. Cannot switch to 5.4.x as it would switch back...

            Is there a way to add this directly to the .project file?

            Show
            Michael Ruoss added a comment - Me, too. Cannot switch to 5.4.x as it would switch back... Is there a way to add this directly to the .project file?
            Hide
            Dennis Tap added a comment -

            The problem with switching to 5.4.x project only happens when je try to change an existing project to 5.4.x. If you setup a new project with 5.4.x php it wil stay on 5.4.x.

            I created a new project and moved my files into the new project.

            Show
            Dennis Tap added a comment - The problem with switching to 5.4.x project only happens when je try to change an existing project to 5.4.x. If you setup a new project with 5.4.x php it wil stay on 5.4.x. I created a new project and moved my files into the new project.
            Hide
            Michael Ruoss added a comment -

            Thanks a lot for this! Using your approach I found out that you can create a file "PATH_TO_PROJECT/.settings/com.aptana.editor.php.prefs" with the following content:

            eclipse.preferences.version=1
            phpVersion=php5.4

            Show
            Michael Ruoss added a comment - Thanks a lot for this! Using your approach I found out that you can create a file "PATH_TO_PROJECT/.settings/com.aptana.editor.php.prefs" with the following content: eclipse.preferences.version=1 phpVersion=php5.4

              People

              • Assignee:
                Shalom Gibly
                Reporter:
                Leo Unglaub
              • Watchers:
                14 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: