Uploaded image for project: 'Aptana Studio'
  1. Aptana Studio
  2. APSTUD-4255

App Explorer and Project Explorer Empty

    Details

    • Type: Bug
    • Status: Open
    • Priority: Low
    • Resolution: Unresolved
    • Affects Version/s: Aptana Studio 3.0.7
    • Fix Version/s: None
    • Labels:
      None
    • Environment:

      Host OS: Windows 7
      OS Arch: x86
      JRE Version: 1.6.0_26

      Description

      Today I updated to the latest version of Aptana.

      When I now creat a new web project (from template and not from template) or I add a new html file, the project/file is not listed in app-explorer or project-explorer.

      I found two related issues, and tried both solutions - however these solutions did not fix the issue:

      https://aptanastudio.tenderapp.com/discussions/problems/2392-build-300201102021251-app-explorer-view-doesnt-show-any-file:

      • I tried customizing the view by clearing all filters and selecting all content.

      http://jira.appcelerator.org/browse/APSTUD-1606
      http://jira.appcelerator.org/browse/APSTUD-1607

      • I tried restarting Eclipse and my RCP product with no luck

      I'm creating a prototype learning product for kids, and I'm using the Aptana plugin. I wanted some of the new features; following an update the above issue started to occur in my Eclipse Install "Version: Indigo Service Release 1 - Build id: 20110916-0149" and the RCP projects I am creating.

      I have attached the following:

      1 - A very light RCP Project:

      • Please import this into Eclipse
      • Set up the Run Configurations
      • Launch as Eclipse Product

      2 - 14 images which describe my experience

      • I've included an image of how the RCP Product looked with the Aptana Plugin before the update. You'll notice the App Explorer and Project Explorer worked perfectly fine
      • The name of each image describes the steps I took
      • Regardless of running the project direct from Eclipse, running from the Product Config or Exporting a Eclipse Product, I get the same results. Restarting makes no difference.

      I noticed the following bug when creating: New From Template --> HTML --> HTML 5 Template:

      when running from Eclipse Launch:
      org.jruby.exceptions.RaiseException: (Errno::EINVAL) =::
      at org.jruby.RubyHash.replace(org/jruby/RubyHash.java:1623)

      when running from Eclipse Product Laucnh:
      !ENTRY org.eclipse.ui 4 4 2012-01-23 20:24:47.141
      !MESSAGE Unable to find Action Set: com.aptana.editor.php.presentation

      Clicking Finish twice when creating a file from HTML 5 Template, completes the task of creating the HTML 5 Template file.

      These bugs are only reported once (Ruby and PHP bug). On subsequent new file templates and new projects creations the Ruby Bug and PHP Action Set Bug do no occur again.

      I would really appreciate some help on this. Even a pointer to the com.aptana.* project which controls the Project and App Explorer.

      I have also noticed another issue with the Aptana Plugin - which is the debugging with Firebug and Firefox version 9.0.1. Is there a Issue you can point me towards?

      Thanks in advance - Parmy

        Attachments

          Activity

            People

            • Assignee:
              pinnamuri Praveen Innamuri (Inactive)
              Reporter:
              parmybrar Parmy Brar
            • Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:

                Git Integration