Aptana Studio
  1. Aptana Studio
  2. APSTUD-3663

JavaScript validation fails trying to parse minified JS as TODO marker

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: High High
    • Resolution: Cannot Reproduce
    • Affects Version/s: Aptana Studio 3.0.5
    • Fix Version/s: None
    • Component/s: js
    • Labels:
    • Environment:

      Windows 7 x64, Aptana Studio b 3.0.5.201110061808

    • Story Points:
      5

      Description

      I get this everytime I try to save, or sometimes it pops up after a while. Really annoying.

      Errors occurred during the build.

      Errors running builder 'JavaScript Validator' on project 'Chrome-CSSEditor'. assertion failed: Marker property value is too long: TODO "},

      {token:"comment.doc",merge:!0,regex:"[^@\\*]+"}

      ,

      {token:"comment.doc",merge:!0,regex:"."}

      ]}};d.inherits(f,e),function()...

      Clearly something is trying to parse minified JS as TODO marker. The file that causes is this:

      https://raw.github.com/ajaxorg/ace/master/build/demo/kitchen-sink.js

      1. kitchen-sink.js
        518 kB
        Ingo Muschenetz

        Activity

        Ingo Muschenetz added a comment -

        Closest I could find was from this checkin (Oct 12th):

        https://raw.github.com/ajaxorg/ace/5c71055d1a77d526f98816741701dd07ae6be318/build/demo/kitchen-sink.js

        File is attached.

        Chris Williams added a comment -

        I can't reproduce this using the 3.1 code. I'm guessing this got fixed by some other changes to our TODO work - probably where we moved from using a Regex to actually iterating over the comments in the AST searching for TODO markers. (This file has TODO inside a string in the code).

        Chris Williams added a comment -

        Unable to reproduce


          People

          • Assignee:
            Chris Williams
            Reporter:
            Jari Pennanen
          • Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development