Uploaded image for project: 'Aptana Studio'
  1. Aptana Studio
  2. APSTUD-253

Wrong character encoding when running HTML Tidy

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Medium
    • Resolution: Won't Fix
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: HTML
    • Labels:
      None

      Description

      {html}<div><p>Assigned to <a href=
      "http://aptanastudio.tenderapp.com/discussions/problems/357-messy-character-encoding-with-html-tidy">
      Tender issue #357</a>. As reported in Tender:</p>
      <blockquote>
      <p>When I use HTML Tidy in Aptana I get the wrong character
      encoding. If I have written "åäö
      ÅÄÖ", HTML Tidy produces "<code>&OElig;
      &Scaron; &scaron; &euro; &hellip;</code>".</p>
      <p>I've tried different text file encoding options (under General
      > Workspace) such as MacRoman, UTF-8 and ISO-8859-1 and none of
      them produces the right result
      "<code>&aring;&auml;&ouml;
      &Aring;&Auml;&Ouml;</code>". I have Aptana Studio,
      build 1.5.1.026124 and Mac OS X 10.5.8.</p>
      <p>Any suggestions on what I am or Aptana is doing wrong?</p>
      </blockquote></div>{html}

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                ingo Ingo Muschenetz
                Reporter:
                aptana1 Aptana
              • Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Git Source Code