Aptana Studio
  1. Aptana Studio
  2. APSTUD-1347

Function return description is missing from both XML and HTML generated documentation files

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Trivial Trivial
    • Resolution: Won't Fix
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: xml
    • Labels:
      None

      Description

      It is about generated documentation: it seems return description is missing from both XML and HTML generated files.

      I have next piece of code:

      /**
       * Get text. This function get some text.
       * @return {String} return some text.
       */
      function getText() {
          return 'text';
      };
      

      and the generated XML is like:

      <function name="getText" ...>
              <description>Get text. This function get some text.</description>
              <return-types>
                 <return-type type="String" />
              </return-types>
      </function>
      

      As you can see return description is missing. Is this intended behavior? I tested on both 1.5.1 and the latest update, standalone and eclipse plugin.</p>

        Activity

        Ingo Muschenetz added a comment -

        This issue is specific to Aptana Studio 2 and will not be addressed.


          People

          • Assignee:
            Ingo Muschenetz
            Reporter:
            Aptana
          • Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development