Uploaded image for project: 'Alloy'
  1. Alloy
  2. ALOY-878

<SplitWindow> not recognized when used with formFactor tags

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Won't Fix
    • Affects Version/s: Alloy 1.2.2
    • Fix Version/s: None
    • Labels:
    • Environment:

      Appcelerator Studio, build: 3.1.3.201309132456, Titanium CLI 3.1.2, Alloy 1.2.2,
      Xcode 5.0.1, OS X 10.8.5

      Description

      I have the following index.xml view:

      <Alloy>
      <Window formFactor="handheld">
      <Label>this is a iPhone Window</Label>
      </Window>
      <SplitWindow formFactor="tablet">
      <Window backgroundColor="red">

      </Window>
      <Window backgroundColor="blue">

      </Window>
      </SplitWindow>
      </Alloy>

      I'm working on a formFactor tags with iphone and ipad layouts using formfactor tags. Whichever one is second never gets processed. If I switch the SplitWindow to be before the <Window> tag, it gets processed but when you start the iphone layout, it won't get processed.

      Attaching a test project. Working on some work with Citi Group and had some questions about iPad / SplitWindow workings with Alloy.

        Attachments

          Activity

            People

            • Assignee:
              tlukasavage Tony Lukasavage
              Reporter:
              jspain Jamil Spain (Inactive)
            • Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Backbone Issue Sync

                • Backbone Issue Sync is enabled for your project, but we do not have any synchronization info for this issue.

                  Git Integration