Uploaded image for project: 'Alloy'
  1. Alloy
  2. ALOY-692

Alloy error output truncated with SDK < 3.0 on Windows

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Medium
    • Resolution: Won't Fix
    • Affects Version/s: Alloy 1.1.2
    • Fix Version/s: None
    • Component/s: Tooling
    • Labels:
    • Environment:

      Alloy v1.0.0-cr
      TiSTUDIO 3.0.2.201302081641
      CLI 3.0.24-cr

      Description

      Problem description

      When building using TiSDK < 3.0.0 , the error message displayed on console is not complete on Windows

      Steps

      Build a project with Alloy 1.0.0 and TiSDK 2.1.4
      Expected result: build fails with error message:

      [ERROR] Alloy 1.0.0+ requires Titanium SDK 3.0.0 or higher.
      [ERROR] Version "2.1.4.GA" was found in the "sdk-version" field of your tiapp.xml.
      [ERROR] If you are building with the old titanium.py script and are specifying an SDK version 
      [ERROR] as a CLI argument that is different than the one in your tiapp.xml, please change the
      [ERROR] version in your tiapp.xml file. 
      [ERROR] Alloy compile failed
      

      Result: on Windows machines, the error message is not complete. However it still contains the first line which include the main information.

      [ERROR] Alloy 1.0.0+ requires Titanium SDK 3.0.0 or higher.
      [ERROR] Alloy compile failed
      

      On OS X and Linux machines is displayed correctly

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                tlukasavage Tony Lukasavage
                Reporter:
                fcasali Federico Casali
              • Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Backbone Issue Sync

                  • Backbone Issue Sync is enabled for your project, but we do not have any synchronization info for this issue.

                    Git Integration