Details

    • Type: Bug
    • Status: Closed
    • Resolution: Invalid
    • Affects Version/s: None
    • Component/s: Appcelerator CLI, Studio
    • Labels:
      None
    • Environment:

      Windows 10.
      Appcelerator Studio 5.1.4

      Description

      I have installed Appcelerator Studio and Android SDK but after Android SDK installation, this is not detected. I have installedSndroid SDK more times with Appcelerator Studio SDK manager and Android Studio SDK manager but never works.

      $ appc ti info -t android
      Appcelerator Command-Line Interface, version 7.1.1
      Copyright (c) 2014-2019, Appcelerator, Inc. All Rights Reserved.

      Android SDK
      Android Executable = not found
      ADB Executable = D:\android-sdk\platform-tools\adb.exe
      SDK Path = D:\android-sdk

      Android NDK
      NDK Path = not found
      NDK Version = not found

      Android Platforms
      1) android-21
      Name = Android 5.0.1 *Not supported by Titanium SDK 8.2.1.GA*
      API Level = 21
      Revision = 2
      Skins = HVGA, QVGA, WQVGA400, WQVGA432, WSVGA, WVGA800, WVGA854, WXGA720, WXGA800, WXGA800-7in
      ABIs = armeabi-v7a, x86, x86_64
      Path = D:\android-sdk\platforms\android-21
      2) android-22
      Name = Android 5.1.1 *Not supported by Titanium SDK 8.2.1.GA*
      API Level = 22
      Revision = 2
      Skins = HVGA, QVGA, WQVGA400, WQVGA432, WSVGA, WVGA800, WVGA854, WXGA720, WXGA800, WXGA800-7in
      ABIs = x86, armeabi-v7a, x86_64
      Path = D:\android-sdk\platforms\android-22
      3) android-23
      Name = Android 6.0
      API Level = 23
      Revision = 3
      Skins = HVGA, QVGA, WQVGA400, WQVGA432, WSVGA, WVGA800, WVGA854, WXGA720, WXGA800, WXGA800-7in, AndroidWearRound, AndroidWearRound360x360, AndroidWearRound400x400, AndroidWearRound480x480, A
      ndroidWearRoundChin320x290, AndroidWearRoundChin320x300, AndroidWearRoundChin360x325, AndroidWearRoundChin360x326, AndroidWearRoundChin360x330, AndroidWearSquare, AndroidWearSquare240x240, AndroidWearSquare320x320
      ABIs = armeabi-v7a, x86, x86_64
      Path = D:\android-sdk\platforms\android-23
      4) android-24
      Name = Android 7.0
      API Level = 24
      Revision = 2
      Skins = HVGA, QVGA, WQVGA400, WQVGA432, WSVGA, WVGA800, WVGA854, WXGA720, WXGA800, WXGA800-7in
      ABIs = x86, arm64-v8a, armeabi-v7a, x86_64
      Path = D:\android-sdk\platforms\android-24
      5) android-25
      Name = Android 7.1.1
      API Level = 25
      Revision = 2
      Skins = HVGA, QVGA, WQVGA400, WQVGA432, WSVGA, WVGA800, WVGA854, WXGA720, WXGA800, WXGA800-7in, AndroidWearRound, AndroidWearRound360x360, AndroidWearRound400x400, AndroidWearRound480x480, A
      ndroidWearRoundChin320x290, AndroidWearRoundChin320x300, AndroidWearRoundChin360x325, AndroidWearRoundChin360x326, AndroidWearRoundChin360x330, AndroidWearSquare, AndroidWearSquare240x240, AndroidWearSquare320x320
      ABIs = x86, armeabi-v7a, x86_64, arm64-v8a
      Path = D:\android-sdk\platforms\android-25
      6) android-26
      Name = Android 8.0.0
      API Level = 26
      Revision = 1
      Skins = HVGA, QVGA, WQVGA400, WQVGA432, WSVGA, WVGA800, WVGA854, WXGA720, WXGA800, WXGA800-7in, AndroidWearRound, AndroidWearRound360x360, AndroidWearRound390x390, AndroidWearRound400x400, A
      ndroidWearRound454x454, AndroidWearRound480x480, AndroidWearRoundChin320x290, AndroidWearRoundChin320x300, AndroidWearRoundChin360x325, AndroidWearRoundChin360x326, AndroidWearRoundChin360x330, AndroidWearSquare, A
      ndroidWearSquare240x240, AndroidWearSquare320x320
      ABIs = x86, x86_64
      Path = D:\android-sdk\platforms\android-26
      7) android-27
      Name = Android 8.1.0
      API Level = 27
      Revision = 1
      Skins = HVGA, QVGA, WQVGA400, WQVGA432, WSVGA, WVGA800, WVGA854, WXGA720, WXGA800, WXGA800-7in
      ABIs = x86, x86_64
      Path = D:\android-sdk\platforms\android-27
      8) android-28
      Name = Android 9
      API Level = 28
      Revision = 1
      Skins = HVGA, QVGA, WQVGA400, WQVGA432, WSVGA, WVGA800, WVGA854, WXGA720, WXGA800, WXGA800-7in, AndroidWearRound, AndroidWearRound360x360, AndroidWearRound390x390, AndroidWearRound400x400, A
      ndroidWearRound454x454, AndroidWearRound480x480, AndroidWearRoundChin320x290, AndroidWearRoundChin320x300, AndroidWearRoundChin360x325, AndroidWearRoundChin360x326, AndroidWearRoundChin360x330, AndroidWearSquare, A
      ndroidWearSquare240x240, AndroidWearSquare320x320
      ABIs = x86, x86_64
      Path = D:\android-sdk\platforms\android-28
      9) android-29
      Name = Android 10 (not supported by Titanium SDK 8.2.1.GA, but may work)
      API Level = 29
      Revision = 1
      Skins = HVGA, QVGA, WQVGA400, WQVGA432, WSVGA, WVGA800, WVGA854, WXGA720, WXGA800, WXGA800-7in
      ABIs = x86, x86_64
      Path = D:\android-sdk\platforms\android-29

      Android Add-Ons
      10) Google Inc.:Google APIs:21
      Name = Google APIs (Android 5.0.1 (API level 21)) *Not supported by Titanium SDK 8.2.1.GA*
      Vendor = Google Inc.
      Revision = 1
      Description = Android + Google APIs
      Skins = HVGA, QVGA, WQVGA400, WQVGA432, WSVGA, WVGA800, WVGA854, WXGA720, WXGA800, WXGA800-7in
      ABIs = armeabi-v7a, x86, x86_64
      Path = D:\android-sdk\add-ons\addon-google_apis-google-21
      Libraries = none

      Android Emulators
      titanium_1_WVGA800
      ID = titanium_1_WVGA800
      SDK Version = not installed
      ABI = x86
      Skin = wvga800
      Path = C:\Users\Meteory\.android\avd\titanium_1_WVGA800.avd
      SD Card = C:\Users\Meteory\.android\avd\titanium_1_WVGA800.avd\sdcard.img
      Google APIs = no

      Genymotion Emulators
      None

      Connected Android Devices
      None

      Android Issues
      ! Unable to locate an Android NDK.
      Without the NDK, you will not be able to build native Android Titanium modules.
      If you have already downloaded and installed the Android NDK, you can tell Titanium where the
      Android NDK is located by running 'appc titanium config android.ndkPath /path/to/android-ndk',
      otherwise you can install it by running 'appc titanium setup android' or manually downloading
      from http://appcelerator.com/android-ndk.

      !
      Android Build Tools 28.0.3 are too new and may or may not work with Titanium.
      If you encounter problems, select a supported version with:
      appc ti config android.buildTools.selectedVersion ##.##.##
      where ##.##.## is a version in that is 28.x

      ! Android API Android 5.0.1 (android-21) is too old and is no longer supported by Titanium SDK
      8.2.1.
      The minimum supported Android API level by Titanium SDK 8.2.1 is API level 23.

      ! Android API Android 5.1.1 (android-22) is too old and is no longer supported by Titanium SDK
      8.2.1.
      The minimum supported Android API level by Titanium SDK 8.2.1 is API level 23.

      ! Android API Android 10 (android-29) is too new and may or may not work with Titanium SDK 8.2.1.
      The maximum supported Android API level by Titanium SDK 8.2.1 is API level 28.

      ! Android API Google APIs (Google Inc.:Google APIs:21) is too old and is no longer supported by
      Titanium SDK 8.2.1.
      The minimum supported Android API level by Titanium SDK 8.2.1 is API level 23.

        Attachments

        1. sdk1.jpg
          sdk1.jpg
          68 kB
        2. sdk2.jpg
          sdk2.jpg
          188 kB
        3. sdk3.jpg
          sdk3.jpg
          88 kB
        4. sdk4.jpg
          sdk4.jpg
          311 kB
        5. sdk5.jpg
          sdk5.jpg
          229 kB

          Activity

            People

            • Assignee:
              shossain Shak Hossain (Inactive)
              Reporter:
              meteoryweb meteoryweb
            • Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Git Source Code