Uploaded image for project: 'Appcelerator - INBOX'
  1. Appcelerator - INBOX
  2. AC-6390

Simulator is not available after app build

    Details

      Description

      Hello,

      I have exactly the same issue as TIMOB-26495 after an unwanted upgrade of Xcode to version 11.

      [INFO] Launching iOS Simulator
      [TRACE] [ioslib] Selected iOS Simulator: iPad Pro (12.9-inch) (3rd generation)
      [TRACE] [ioslib] UDID = D5C9F731-10D9-439B-AE2B-E1068B578A6E
      [TRACE] [ioslib] iOS = 12.1
      [TRACE] [ioslib] Autoselected Xcode: 10.3
      [TRACE] [ioslib] Checking if the simulator /Applications/Xcode_10_3.app/Contents/Developer/Applications/Simulator.app/Contents/MacOS/Simulator is already running
      [TRACE] [ioslib] Simulator is not running
      [TRACE] [ioslib] Tailing iPad Pro (12.9-inch) (3rd generation) Simulator system log: /Users/lfaure/Library/Logs/CoreSimulator/D5C9F731-10D9-439B-AE2B-E1068B578A6E/system.log
      [ERROR] Simulator is not available

      The simulator exists as it is showing with commands appc ti info and xcrun simctl list devices, I mention the simulator id for each build with no success.

      The app launches fine when installed on the simulator manually.

      Here is what I attempted so far :

      Testing with XCode versions 10.1, 10.3 and 11 (with complete uninstall / reinstall)
      Deleting / re-adding simulators
      Deleting / addding ios versions components
      Rebooting computer
      Trying different TiSDK versions
      Eventually deinstalling / reinstalling everything (Appcelerator, Xcode, Titanium CLI, etc)

      I have not found any solution anywhere, do you have any idea ?

        Attachments

          Activity

            People

            • Assignee:
              morahman Motiur Rahman
              Reporter:
              lfaure Léna Faure
            • Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Git Integration