Uploaded image for project: 'Appcelerator - INBOX'
  1. Appcelerator - INBOX
  2. AC-6110

Breakpoints are ignored in Appcelerator Studio 5.5.1.x in Debug mode

    Details

    • Type: Bug
    • Status: Resolved
    • Resolution: Needs more info
    • Affects Version/s: None
    • Labels:
      None
    • Environment:

      Description

      I while I can set breakpoints in Studio they are ignored when launch in debug mode. The debugger keyword is also ignored and does not cause an error.

      I am using the currently latest version 5.1.1 with Ti SDK 7.5.0.GA against iPhone X Simulator using iOS 12.1. I've selected Debug mode, targeting iPhone X Simulator. I have not tried this with Android.

      I've tried my own apps and new Classic as well as new Alloy projects as well as Kitchen sink.

      I did not find any CLI options that would yield a different result. How can one troubleshoot if the issue is Studio or CLI?

      This issue is also posted on Stack Overflow.

      The Studio log file is attached. Trying to generate the Studio daemon log resulted in the following message: "Unable to generate Appc Daemon dump file, maybe due to appc daemon is not running or not available".

      P.S.: This JIRA does not list the latest version of Studio as an option.

        Attachments

          Activity

            People

            • Assignee:
              shossain Shak Hossain (Inactive)
              Reporter:
              chrishaff@gmail.com chrishaff@gmail.com
            • Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Git Integration