Uploaded image for project: 'Appcelerator - INBOX'
  1. Appcelerator - INBOX
  2. AC-5996

App Studio not finding GenyMotion Virtual Devices

    Details

    • Type: Bug
    • Status: Resolved
    • Resolution: Not Our Bug
    • Affects Version/s: None
    • Component/s: Appcelerator CLI, Studio
    • Labels:
      None
    • Environment:

      Mac OSX Mojave, Axway Appcelerator Studio, build: 5.1.1.201809051655, SDK 7.4.1

      Description

      AppStudio is no longer finding the Genymotion virtual devices. I have un-installed, re-installed Studio and Genymotion with no luck. If I connect a physical device then it works but not a Genymotion device even though both are visible via ADB as follows:

      $ adb devices -l
      List of devices attached
      ZY222ZTPKD device usb:339738624X product:osprey_reteu_2gb model:MotoG3 device:osprey_u2 transport_id:3
      192.168.62.101:5555 device product:vbox86p model:Samsung_Galaxy_S8___7_0_0__API_24__1440x2960 device:vbox86p transport_id:4

      Seems as though App Studio does not like a device with a short name of an IP address, only thing I can think off.

      If I use

      $ appc ti info

      the following is shown which is correct

      Genymotion
      Path = /Applications/Genymotion.app/Contents/MacOS
      Genymotion Executable = /Applications/Genymotion.app/Contents/MacOS/genymotion
      Genymotion Player = /Applications/Genymotion.app/Contents/MacOS/player.app/Contents/MacOS/player
      Home = /Users/<user>/.Genymobile/Genymotion

      VirtualBox
      Executable = /usr/local/bin/VBoxManage
      Version = 5.2.20r125813

        Attachments

          Activity

            People

            • Assignee:
              shossain Shak Hossain (Inactive)
              Reporter:
              developer@tpglobalpartners.com Nigel Underwood
            • Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Git Source Code