Uploaded image for project: 'Appcelerator - INBOX'
  1. Appcelerator - INBOX
  2. AC-5986

XCode10: Enterprise AdHoc build broken (CLI 7.0.6+SDK 7.4.1)

    Details

    • Type: Bug
    • Status: Resolved
    • Resolution: Invalid
    • Affects Version/s: None
    • Labels:
      None
    • Environment:

      Description

      In the process of upgrading to Titanium SDK 7.4.1.GA (as of some major issues with iOS12), I've installed and set up latest XCode 10.0, but running an Enterprise AdHoc build gives me the error

      [INFO] :   Invoking xcodebuild
      [INFO] :   Packaging for Ad Hoc distribution
      [ERROR] :  Failed to export archive to ipa
      [ERROR] :  The selected provisioning profile "Corporate App (abc123)" is most likely not a valid Ad Hoc provisioning profile.
      [ERROR] :  Please ensure you are using a valid Ad Hoc provisioning that is linked to the signing identity, then try again.
      

      this is the build command:

      appc run -p ios -T dist-adhoc -R 'CorporationName' --pp-uuid abc123 -O ./ --ios-version 12.0 --distribution-name 'CorporationName' --deploy-type production --project-dir ./
      

      Switching the XCode CLI build tools back to 9.2 and using the --ios-version 11.2 flag builds and packages the app correctly.

      Unfortunately, the iOS12 crashes seem to persist, so I assume I have to get it going with XCode10 to take full advantage of Ti SDK 7.4.1.GA

      Could you please help me with this?

        Attachments

          Activity

            People

            • Assignee:
              shossain Shak Hossain (Inactive)
              Reporter:
              mkainzbauer Martin Kainzbauer
            • Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Git Source Code