Uploaded image for project: 'Appcelerator - INBOX'
  1. Appcelerator - INBOX
  2. AC-5765

Titanium SDK 5.3.0.GA failed to build on iOS devices

    Details

      Description

      When building an ad-hoc version of my application, it fails with the following error.

      _2018-06-07T10:48:35.919Z | ERROR | An uncaught exception was thrown!
      2018-06-07T10:48:35.921Z | ERROR | Cannot read property 'devices' of undefined
      2018-06-07T10:48:35.921Z | TRACE | TypeError: Cannot read property 'devices' of undefined
      at iOSBuilder.<anonymous> (/Users/innovator/Library/Application Support/Titanium/mobilesdk/osx/5.3.0.GA/iphone/cli/commands/_build.js:298:12)
      Cannot read property 'devices' of undefined
      at /Users/innovator/Library/Application Support/Titanium/mobilesdk/osx/5.3.0.GA/node_modules/ioslib/index.js:115:12
      at /Users/innovator/Library/Application Support/Titanium/mobilesdk/osx/5.3.0.GA/node_modules/ioslib/node_modules/async/lib/async.js:726:13
      at /Users/innovator/Library/Application Support/Titanium/mobilesdk/osx/5.3.0.GA/node_modules/ioslib/node_modules/async/lib/async.js:52:16
      at done (/Users/innovator/Library/Application Support/Titanium/mobilesdk/osx/5.3.0.GA/node_modules/ioslib/node_modules/async/lib/async.js:241:17)
      at /Users/innovator/Library/Application Support/Titanium/mobilesdk/osx/5.3.0.GA/node_modules/ioslib/node_modules/async/lib/async.js:44:16
      at /Users/innovator/Library/Application Support/Titanium/mobilesdk/osx/5.3.0.GA/node_modules/ioslib/node_modules/async/lib/async.js:723:17
      at /Users/innovator/Library/Application Support/Titanium/mobilesdk/osx/5.3.0.GA/node_modules/ioslib/node_modules/async/lib/async.js:167:37
      at /Users/innovator/Library/Application Support/Titanium/mobilesdk/osx/5.3.0.GA/node_modules/ioslib/index.js:85:6
      at /Users/innovator/Library/Application Support/Titanium/mobilesdk/osx/5.3.0.GA/node_modules/ioslib/lib/device.js:51:12
      _

      I tried cleaning everything about Appcelerator and reinstall but no luck. What else can I do?
      While googling found some fixes, which says to downgrade the Node.js version to 4.4.x (Currently I'm using node version 8.9.1). But when I change the node js to 4.4.x, the Appcelerator throws an error saying "appc requires Node.js >=8.0.0".

      Please help me to solve this error.

      *Please find my environment details below, *
      Operating System: mac os 10.13.4
      Studio: Axway Appcelerator Studio, build: 5.0.0.201712081732
      Application's Titanium SDK version: 5.3.0.GA
      Node.js
      Node.js Version = 8.9.1
      npm Version = 5.5.1

      Appcelerator CLI
      Installer = 4.2.13
      Core Package = 7.0.3

      Titanium CLI
      CLI Version = 5.1.0
      node-appc Version = 0.2.44

        Attachments

          Activity

            People

            • Assignee:
              shossain Shak Hossain (Inactive)
              Reporter:
              sujith sujith
            • Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Git Integration