Uploaded image for project: 'Appcelerator - INBOX'
  1. Appcelerator - INBOX
  2. AC-5588

iOS: Videoplayer's native control is not working properly

    Details

    • Type: New Feature
    • Status: Resolved
    • Resolution: Duplicate
    • Affects Version/s: None
    • Component/s: Alloy, Titanium SDK & CLI
    • Labels:
      None
    • Environment:

      Appcelerator Studio 4.10.0
      Ti SDK 6.3.0GA
      iOS 11

      Description

      We have using the Demo code.
      var vidWin = Titanium.UI.createWindow(

      { title : 'Video View Demo', backgroundColor : '#fff' }

      );

      var videoPlayer = Titanium.Media.createVideoPlayer(

      { top : 2, autoplay : false, backgroundColor : 'blue', height : 300, width : 300, mediaControlStyle : Titanium.Media.VIDEO_CONTROL_EMBEDDED, scalingMode : Titanium.Media.VIDEO_SCALING_ASPECT_FIT, showControl : true }

      );

      videoPlayer.url = '\video.mp4';
      vidWin.add(videoPlayer);
      vidWin.open();

      Now we can click on the fullscreen buttton.
      At the bottom, there are forward/backward and pause button.

      Pause button works properly. but forward and the backward button does nothing and video gets stuck.

      Also, there is one more issue if we give background color as black or any other it does not show the default loading indicator at all. It shows only when the background color is blue.

      Please let me know if I am missing anything.

      Thanks.

        Attachments

          Activity

            People

            • Assignee:
              shossain Shak Hossain
              Reporter:
              shumne shumne
            • Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Git Source Code