Uploaded image for project: 'Appcelerator - INBOX'
  1. Appcelerator - INBOX
  2. AC-555

appc setup throws error on windows 10 (trying to install fsevents an os x only module)...

    Details

    • Type: Bug
    • Status: Resolved
    • Resolution: Cannot Reproduce
    • Affects Version/s: Appcelerator Studio 4.5.0
    • Component/s: Appcelerator CLI, Studio
    • Labels:
    • Environment:

      Windows 10.0.10586, node (0.12.9 or 4.2.4 or 5.3.0), npm 3.5.2

      Description

      appc setup
      Finding latest version ...5.1.0 OK
      Validating security checksum OK
      Installing ... OK
      Compiling platform native modules ...
      └ extract-opts/typechecker ... OK
      └ bunyan/dtrace-provider ... OK
      └ extract-opts/typechecker ... OK
      └ socket.io-client/ws ... OK
      └ appc-ldapjs/dtrace-provider ... OK
      └ bunyan/dtrace-provider ... OK
      └ appc-ldapjs/dtrace-provider ... OK
      └ ws/bufferutil ... OK
      └ ws/utf-8-validate ... OK
      └ chokidar/fsevents ... npm ERR! Windows_NT 10.0.10586
      npm ERR! argv "C:
      Program Files (x86)
      Nodist/v/nodev0.12.9/node.exe" "C:
      Program Files (x86)\\Nodist\\bin\\node_modules\\npm\\bin
      npm-cli.js" "install" "fsevents@1.0.5" "--production"
      npm ERR! node v0.12.9
      npm ERR! npm v3.5.2
      npm ERR! code EBADPLATFORM

      npm ERR! notsup Not compatible with your operating system or architecture: fsevents@1.0.5
      npm ERR! notsup Valid OS: darwin
      npm ERR! notsup Valid Arch: any
      npm ERR! notsup Actual OS: win32
      npm ERR! notsup Actual Arch: ia32

      npm ERR! Please include the following file with any support request:
      npm ERR! C:\Users\dspells\.appcelerator\install\5.1.0\package\node_modules\arrow\node_modules\babel\node_modules\chokidar\npm-debug.log

      C:\Users\dspells>nodist ls
      > nodev0.12.9 (global)
      nodev4.2.4
      nodev5.3.0

      C:\Users\dspells>nodist 4.2.4
      nodev4.2.4

      C:\Users\dspells>appc setup
      Finding latest version ...5.1.0 OK
      Validating security checksum OK
      Installing ... OK
      Compiling platform native modules ...
      └ extract-opts/typechecker ... OK
      └ bunyan/dtrace-provider ... OK
      └ extract-opts/typechecker ... OK
      └ socket.io-client/ws ... OK
      └ appc-ldapjs/dtrace-provider ... OK
      └ bunyan/dtrace-provider ... OK
      └ appc-ldapjs/dtrace-provider ... OK
      └ ws/bufferutil ... OK
      └ ws/utf-8-validate ... OK
      └ chokidar/fsevents ... npm ERR! Windows_NT 10.0.10586
      npm ERR! argv "C:
      Program Files (x86)\\Nodist\\v\\nodev4.2.4
      node.exe" "C:
      Program Files (x86)\\Nodist\\bin\\node_modules\\npm\\bin
      npm-cli.js" "install" "fsevents@1.0.5" "--production"
      npm ERR! node v4.2.4
      npm ERR! npm v3.5.2
      npm ERR! code EBADPLATFORM

      npm ERR! notsup Not compatible with your operating system or architecture: fsevents@1.0.5
      npm ERR! notsup Valid OS: darwin
      npm ERR! notsup Valid Arch: any
      npm ERR! notsup Actual OS: win32
      npm ERR! notsup Actual Arch: ia32

      npm ERR! Please include the following file with any support request:
      npm ERR! C:\Users\dspells\.appcelerator\install\5.1.0\package\node_modules\arrow\node_modules\babel\node_modules\chokidar\npm-debug.log

      C:\Users\dspells>nodist 5.3.0
      nodev5.3.0

      C:\Users\dspells>appc setup
      Finding latest version ...5.1.0 OK
      Validating security checksum OK
      Installing ... OK
      Compiling platform native modules ...
      └ extract-opts/typechecker ... OK
      └ bunyan/dtrace-provider ... OK
      └ extract-opts/typechecker ... OK
      └ socket.io-client/ws ... OK
      └ appc-ldapjs/dtrace-provider ... OK
      └ bunyan/dtrace-provider ... OK
      └ appc-ldapjs/dtrace-provider ... OK
      └ ws/bufferutil ... OK
      └ ws/utf-8-validate ... OK
      └ chokidar/fsevents ... npm ERR! Windows_NT 10.0.10586
      npm ERR! argv "C:
      Program Files (x86)\\Nodist\\v\\nodev5.3.0
      node.exe" "C:
      Program Files (x86)\\Nodist\\bin\\node_modules\\npm\\bin
      npm-cli.js" "install" "fsevents@1.0.5" "--production"
      npm ERR! node v5.3.0
      npm ERR! npm v3.5.2
      npm ERR! code EBADPLATFORM

      npm ERR! notsup Not compatible with your operating system or architecture: fsevents@1.0.5
      npm ERR! notsup Valid OS: darwin
      npm ERR! notsup Valid Arch: any
      npm ERR! notsup Actual OS: win32
      npm ERR! notsup Actual Arch: ia32

      npm ERR! Please include the following file with any support request:
      npm ERR! C:\Users\dspells\.appcelerator\install\5.1.0\package\node_modules\arrow\node_modules\babel\node_modules\chokidar\npm-debug.log

        Attachments

          Activity

            People

            • Assignee:
              sdarda Sharif AbuDarda (Inactive)
              Reporter:
              dspells Henry David Spells III
            • Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Git Integration