Uploaded image for project: 'Appcelerator - INBOX'
  1. Appcelerator - INBOX
  2. AC-5449

Slider not working within ListView - IOS

    Details

    • Type: Bug
    • Status: Resolved
    • Resolution: Needs more info
    • Affects Version/s: Appcelerator Studio 4.5.0
    • Component/s: Alloy, Appcelerator CLI
    • Labels:
    • Environment:

      SDK 6.2.0 and above
      CLI 6.2.0 and above
      Axway Appcelerator Studio 4.0

      Description

      Slider was working when placed inside ListView until SDK 6.1.2. After 6.2.0, the pointer just stay on the end points on either sides of the slider. Attached graphs show the different before and after the change since 6.1.2

      My sample code simply use the slider to show the stock price day range and the current relative position.

      <ListView id='stocklistview’ >
      <Templates>
      <ItemTemplate id=‘default_template' >
      <View id='sliderView'>
      <Slider id='dayrangeslider' bindId='dayrangeslider' touchEnabled='false' />
      </View>
      </ItemTemplate>
      </Templates>
      <ListSection id='stocklistsection' dataCollection='stocklist' dataTransform='transformdisplay'>
      <ListItem canEdit='true'
      dayrangeslider:min='

      {dayslow}'
      dayrangeslider:max='{dayshi}'
      dayrangeslider:minRange='{dayslow}

      '
      dayrangeslider:maxRange='

      {dayshi}

      '
      dayrangeslider:value='

      {lasttradeprice}

      '
      />
      </ListSection>
      </ListView>

        Attachments

          Activity

            People

            • Assignee:
              shossain Shak Hossain
              Reporter:
              tlau Tony Lau
            • Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Git Source Code