Uploaded image for project: 'Appcelerator - INBOX'
  1. Appcelerator - INBOX
  2. AC-4868

Building from CLI for Android device throws 'Failed to package application' error

    Details

    • Type: Bug
    • Status: Closed
    • Resolution: Invalid
    • Affects Version/s: Appcelerator Studio 4.5.0
    • Component/s: Titanium SDK & CLI
    • Labels:
    • Environment:

      Windows 10 Professional
      Java 8 32 bits
      Titanium SDK 6.0.2.GA, 6.0.1.GA, 5.5.1.GA
      Alloy 1.9.8
      Titanium CLI 5.0.12
      NPM 3.8.3
      Node 5.10.1

      Description

      I'm trying to build an Alloy test project using the CLI. I followed the instructions from here.

      But whenever I run the command

      ti build -p android -T device

      I get the following error as it's finishing to try and generate the APK:

      [INFO] Generating C:\Titanium\workspace\AppTest4\build\android\res\values\theme.xml
      [INFO] Packaging application: c:\Android\SDK\build-tools\24.0.0\aapt.exe "package" "f" "-m" "-J" "C:\Titanium\workspace\AppTest4\build\android\gen" "-M" "C:\Titanium\workspace\AppTest4\build\android\AndroidManifest.xml" "-A" "C:\Titanium\workspace\AppTest4\build\android\bin\assets" "-S" "C:\Titanium\workspace\AppTest4\build\android\res" "-I" "c:\Android\SDK\platforms\android-23\android.jar" "-F" "C:\Titanium\workspace\AppTest4\build\android\bin\app.ap_" "auto-add-overlay" "-extra-packages" "ti.modules.titanium.ui:android.support.v7.appcompat:android.support.v7.cardview" "-S" "C:\Users\AGUSTN~1\AppData\Local\Temp\117222-4892-jevz47/res" "-S" "C:\Users\AGUSTN~1\AppData\Local\Temp\117222-4892-1b4s1oy/res" "-S" "C:\Users\AGUSTN~1\AppData\Local\Temp\117222-4892-1ik5kyr/res"
      [ERROR] Failed to package application:
      [ERROR]
      [ERROR]

      The full build log can be found in my attachments.

      I have tried creating sample projects using Titanium SDK 6.0.2.GA, 6.0.1.GA and 5.5.1.GA, but none have been successful at generating the APK.

      The way I generate the projects from CLI is using the following commands:

      ti create --id com.mycompany.myapp -d . -n APPNAME -p android -t app -u http://mycompany.com
      cd APPNAME/
      alloy new

      Are there any know causes for this issue?

      I attach the log from the command 'appc ti info -p android' when run with Titanium SDK 6.0.2.GA, 6.0.1.GA and 5.5.2.GA selected.

        Attachments

          Activity

            People

            • Assignee:
              shossain Shak Hossain
              Reporter:
              auamendoza88 Uriel Arvizu
            • Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Git Source Code