Details

    • Type: Bug
    • Status: Closed
    • Resolution: Cannot Reproduce
    • Affects Version/s: None
    • Component/s: Appcelerator Modules
    • Labels:
    • Environment:

      Description

      I have a map where I add annotations with custom icons. Works fine on Ti.SDK 5.5.0 and ti.map 2.3.6.

      However, I had to update to try and solve an issue with click events on a map with polygons on it (http://stackoverflow.com/questions/40908639/click-events-on-polygons-in-ti-map-are-slow-on-android). It does not solve the problem - but ti.map 3.1.0 is kind of more stable - but still dead-slow

      However, this exercise led to the issue with custom icons not being shown. It seems related to another issue: https://jira.appcelerator.org/browse/AC-4647 that I understand you could not reproduce.

      Simple example showing how I add the annotation:

          var annotationView = Ti.UI.createView({
              width:50,
              height:50,
              opacity:0.8,
              backgroundColor:'#2a3b0a',  // Darker green
              borderRadius:25
          });
           
          //Add image to the annotation view
          var imageView = Ti.UI.createImageView({
                  width:35,
                  height:35,
                  opacity:1,
                  image: '/images/zeroTrip.png'
              });
          annotationView.add(imageView);
          mapView.addAnnotation(
              Map.createAnnotation({
                  latitude: e.coords.latitude, 
                  longitude: e.coords.longitude,
                  title:"Test icon",
                  subtitle:"06-12-2016",
                  image:annotationView.toImage()
              })
          );
      

      I have attached the image file, and screenshots of iPhone and Android

      Edit
      I might have gotten confused here (many things in play) - and I don't use our app regularly on an Android device. It appears that the way it worked before was by not showing the custom icon - but just a regular red annotation pin....

      And now it is not showing the pin nor an image - so you could say in the process of approaching a custom icon

      The change is related to ti.map. It works with the pins back in 2.3.6

      Sorry for the confusion!

        Attachments

          Activity

            People

            • Assignee:
              shossain Shak Hossain
              Reporter:
              jda John Dalsgaard
            • Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Git Source Code