Uploaded image for project: 'Appcelerator - INBOX'
  1. Appcelerator - INBOX
  2. AC-4630

[Android] Not able to complie/build any new/old module with the new SDK 6.0.0.GA

    Details

    • Type: Bug
    • Status: Closed
    • Resolution: Fixed
    • Affects Version/s: None
    • Component/s: None
    • Environment:

      Description

      I cant build any module anymore with the new sdk 6.0.0.GA.
      I suspect it has got to do with the incompatible android NDK been used as the new sdk is making used of the latest V8 whereas the android NDK been used in the titanium studio is quit old and outdated. I tried installing the latest ndk revison 13 and tried compilling but that also always seems to ends up with some messy error.

      This incompatibility has prevent all my projects from making use of the latest sdk 6 and had me still stuck at 5.5.1 sdk because my app make uses of a lot of external modules.

      Steps to reproduce :
      1. Go to titanium studio
      2. Create new mobile module project with android as the deployment target using the sdk 6.0.0.GA version.
      3. Put the android ndk path in the build.properties.
      4. run as Ant Build.

      The compiling never succeeds but always throws up some error [related to android NDK most probably]

        Attachments

          Activity

            People

            • Assignee:
              shossain Shak Hossain
              Reporter:
              spaceman12 Lee phela
            • Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Backbone Issue Sync

                • It looks like Backbone Issue Sync is not enabled for your project.

                  Git Source Code