Uploaded image for project: 'Appcelerator - INBOX'
  1. Appcelerator - INBOX
  2. AC-4546

App deployed with development settings

    Details

    • Type: Bug
    • Status: Closed
    • Resolution: Needs more info
    • Affects Version/s: None
    • Component/s: Alloy, Titanium SDK & CLI
    • Environment:

      Ti SDK 5.* (any as far as I know), Mac 10.11.6 (Mac version could be unrelated)

      Description

      Yesterday I published the Android version of an app; later I found out it used the development config in `config.json` instead of production.

      I have had this issue once before and it is likely because of the message:

      `[INFO] : [config.json] config.json unchanged, using cached config.json...`

      I've got a strong feeling this isnt working properly. I had just updated my config.json, (I believe without using `AppcStudio -> Project -> Clean...` before I packaged the project) and it used the development config.

      Later I built the iOS app (not knowing the issue on the Android package yet) and it appeared to build correctly.

      I hereby suggest: dont use any sort of "cache" function for such simple files as `config.json`. This file is likely not gonna be bigger than 200 lines and not caching it is probably the easiest fix.

        Attachments

          Activity

            People

            • Assignee:
              shossain Shak Hossain
              Reporter:
              uzbbert Bert
            • Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Git Source Code