Uploaded image for project: 'Appcelerator - INBOX'
  1. Appcelerator - INBOX
  2. AC-385

Tableview SetData not working when coming back from other View

    Details

    • Type: Bug
    • Status: Resolved
    • Resolution: Needs more info
    • Affects Version/s: None
    • Component/s: None
    • Environment:

      Windows 7 X64
      Appcelerator Studio 4.3
      Titaium SDK 4.1.1

      Description

      Im faceing the following bug:

      When I have a view and enter it via View.open(); a Tableview which is generated in in JS it works fine.

      I can delete and add Data via TableView.data=someData or Tableview.setData(someData).

      But if i use the same View and return to it (via Backbutton or NavigationButton) i cannot add or new entries to the TableView.

      if I check the TableView in the Debugger after using TableView.setdata(someData) or TableView.data= someData the entries are there but are not displayed on the device (it is just blank where the TableView should be)

      On the other hand if i return to the Page where the View (with the TableView) is opened via View.open() it's starts to function again.

      This problem occures on android and on ios

        Attachments

          Activity

            People

            • Assignee:
              shossain Shak Hossain
              Reporter:
              blackbilbao Ilja Schwarz
            • Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Git Source Code