Details

    • Type: Bug
    • Status: Closed
    • Resolution: Needs more info
    • Affects Version/s: Appcelerator Studio 4.5.0
    • Component/s: Appcelerator Modules
    • Labels:
    • Environment:
      • Mac OS 10.11.2
      • Ti SDK 5.3.0.GA
      • Ti CLI 5.0.8
      • Android 23
      • Eclipse Java Development Tools 3.9.2v20140221-1700

      Description

      I'm trying to build this module tiadbuddiz-android, but the terminal gives me this error message: terminal log

      Titanium Command-Line Interface, CLI version 5.0.8, Titanium SDK version 5.3.0.GA
      Copyright (c) 2012-2015, Appcelerator, Inc.  All Rights Reserved.
       
      Please report bugs to http://jira.appcelerator.org/
       
      [ERROR] Unable to compile project because the 'sdk-version' in the tiapp.xml is not installed
       
      The project's sdk-version is currently set to 3.2.0.GA, which is not installed.
       
      Update the sdk-version in the tiapp.xml to one of the installed Titaniums SDKs:
          3.5.2.v20160311103211
          4.1.1.v20160311104258
          5.1.1.GA
          5.1.2.GA
          5.2.0.GA
          5.2.2.GA
          5.3.0.GA
      or run 'titanium sdk install 3.2.0.GA' to download and install Titanium SDK 3.2.0.GA
      

      I also tried using the CLI, but I get this other error:

       
      Mac-mini-di-Vittorio:android Astrovic$ appc ti build -p android --build-only
      Appcelerator Command-Line Interface, version 5.3.0
      Copyright (c) 2014-2016, Appcelerator, Inc.  All Rights Reserved.
       
      2016-06-09 18:20:33
       
      Operating System
        Name                        = Mac OS X
        Version                     = 10.11.2
        Architecture                = 64bit
        # CPUs                      = 4
        Memory                      = 8589934592
       
      Node.js
        Node.js Version             = 0.12.7
        npm Version                 = 2.11.3
       
      Titanium CLI
        CLI Version                 = 5.0.8
       
      Titanium SDK
        SDK Version                 = 5.3.0.GA
        SDK Path                    = /Users/Astrovic/Library/Application Support/Titanium/mobilesdk/osx/5.3.0.GA
        Target Platform             = android
       
      Command
        /usr/local/bin/node /Users/Astrovic/.appcelerator/install/5.3.0/package/node_modules/titanium/lib/titanium.js build -p android --build-only --config-file /var/folders/y8/8j10jk95439019w_n7scwm_80000gn/T/build-1465489225484.json --log-level info --no-banner --project-dir /Users/Astrovic/Dati/Applicazioni/tiadbuddiz/android
       
      [WARN]  The ti.deploytype tiapp.xml property has been deprecated, please use the --deploy-type option
       
      [WARN]  <tool-api-level> has been deprecated, please specify the target SDK API using the <uses-sdk> tag:
      [WARN]   
      [WARN]  <ti:app xmlns:ti="http://ti.appcelerator.org">
      [WARN]      <android>
      [WARN]          <manifest>
      [WARN]              <uses-sdk android:minSdkVersion="14" android:targetSdkVersion="23" android:maxSdkVersion="23"/>
      [WARN]          </manifest>
      [WARN]      </android>
      [WARN]  </ti:app>
       
      [ERROR] The target SDK API 15 is not supported by Titanium SDK 5.3.0
      [ERROR] The target SDK API version must be 23 or newer
       
      Update the android:targetSdkVersion in the tiapp.xml or custom AndroidManifest to at least 23:
       
      <ti:app xmlns:ti="http://ti.appcelerator.org">
          <android>
              <manifest>
                  <uses-sdk android:minSdkVersion="14" android:targetSdkVersion="23" />
              </manifest>
          </android>
      </ti:app>
      
      

        Attachments

          Activity

            People

            • Assignee:
              aislam Aminul Islam
              Reporter:
              astrovicapps Vittorio Sorbera
            • Watchers:
              9 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Git Source Code