Uploaded image for project: 'Titanium SDK/CLI'
  1. Titanium SDK/CLI
  2. TIMOB-23457

Build of project through command "appc ti build" on the end always returns code zero

    Details

    • Type: Bug
    • Status: Open
    • Priority: High
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Tooling
    • Labels:
    • Environment:

      TITANIUM_SDK = 5.0.2.GA
      CLI Version = 5.0.6
      Xcode - 7.2.1 (build 7C1002)

      Description

      I have the shell script for automatic creation build for iOS and Android but when the build script finished independently whether will finished with some error or success the returned code is always zero.

      For example:

      ~$ appc ti build --platform ios --project-dir "/mylocalWorkspace" -T dist-appstore --sdk "TitaniumSDK" -R "someCertificate" -P "someProvisioningProfile"
      ~$ echo $?

      EXPECTATION
      When build finished with some error the script always returns code different than zero, that means success finishing.

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              vladimir.altiparmakov@seavus.com Vladimir
            • Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:

                Backbone Issue Sync

                • Titanium SDK/CLI <> Titanium Mobile
                  Synced with:
                  TIMOB-9786
                  Sync status:
                  ERROR
                  Last received:
                  Last sent:

                  Git Integration