Uploaded image for project: 'Appcelerator - INBOX'
  1. Appcelerator - INBOX
  2. AC-2585

Longjohn error on 3 separate machines when building with 3.2.1.GA

    Details

    • Type: Bug
    • Status: Resolved
    • Resolution: Fixed
    • Affects Version/s: None
    • Component/s: None
    • Environment:

      Mac OSX Mavericks
      Node 0.10.13
      Titanium CLI 3.2.1
      Titanium SDK 3.2.1
      TitaniumStudio 3.2.1
      Xcode 5.0.2

      Description

      I cannot get any projects to build under Titanium SDK 3.2.1.GA. I updated 3 separate systems and I can't build out a project in TitaniumStudio or the Titanium CLI on any of them. My preferred method for the past year has been the CLI. All attempts are returning the exact same error:

      ti build

      /usr/local/lib/node_modules/titanium/node_modules/longjohn/dist/longjohn.js:184
      throw e;
      ^
      [object Object]

      I've tried building current projects that work fine in 3.1.3.GA. I've tried creating brand new projects (which works fine) and then building them, same error. I've run through the setup to make sure everything was filled out and get the error when selecting Check Environment or iOS settings.

      I don't ever get more robust errors like I've seen in other tickets, it's always ended with [object Object] and no details about what's throwing the error exactly. If I switch my default SDK back to 3.1.3 and change it in tiapp.xml back to 3.1.3 everything works fine.

      I am running ti CLI on 3 different machines all with exactly the same issue, so I must have something setup wrong on all 3 machines.

      I've dug in a little deeper and if I type 'ti -v' at the command prompt I get back 3.2.1, and if I type 'which ti' I get back /usr/local/bin/ti. Now if I type 'ls -la /usr/local/bin/ti' I get back:

      lrwxr-xr-x 1 root admin 41 Feb 19 01:11 /usr/local/bin/ti -> ../lib/node_modules/titanium/bin/titanium

      And finally if I type in '/usr/lib/node_modules/titanium/bin/titanium -v' I get back 3.1.2, which makes absolutely no sense to me. Why would 'ti -v' give me 3.2.1 but when I use the full path to where the 'ti' command is linked it gives me back 3.1.2? I must have messed something up along the way but I'm not necessarily sure how it relates to the longjohn error I'm seeing and what I need to do to fix it. I've uninstalled and reinstalled the titanium cli through npm several times and haven't seen changes in any of the behavior above.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                cbarber Chris Barber
                Reporter:
                thisishuey Jeff "Huey" Huelsbeck
              • Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Git Source Code