Uploaded image for project: 'Appcelerator - INBOX'
  1. Appcelerator - INBOX
  2. AC-2024

Cannot Launch / Build iOS app with New Appcelerator SDK and new Xcode

    Details

    • Type: Bug
    • Status: Closed
    • Resolution: Invalid
    • Affects Version/s: None
    • Component/s: None
    • Environment:

      Mac OS X Lion

      Description

      Hi there-

      I am building an iOS app after an upgrade to the 2.1.3 GA Titanium SDK. I also have XCode v 4.5.1 w/ the iOS 6 SDK. I uninstalled the previous XCode versions.

      When attempting to build, I get the following error:

      dyld: Library not loaded: @rpath/DevToolsFoundation.framework/Versions/A/DevToolsFoundation
      Referenced from: /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneSimulator.platform/Developer/Library/PrivateFramework
      Reason: image not found

      I noticed in the 2.1.3 Release notes that there was an issue relating to this (I believe), since the latest XCode has moved the Development directory:

      TIMOB-10854

      ...yet, I am still encountering this issue. Any ideas to get past this to continue the install?

        Attachments

          Activity

            People

            • Assignee:
              mpmiranda Mauro Parra-Miranda
              Reporter:
              cpatrick Christopher R McGuire
            • Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Git Source Code