Uploaded image for project: 'Appcelerator - INBOX'
  1. Appcelerator - INBOX
  2. AC-1698

Weird Click Event Inconsistency with 3.5.0GA and Appcelerator NavigationWindow and RightNavButtons

    Details

      Description

      when you use this code, sometimes the click event on the button is ignored... nothing shows up in the alert when you click using the latest 3.5.0 SDK on IOS

      This code is inconsistent

      <Alloy>
          <NavigationWindow id="nav" formFactor="handheld">
              <Window id="win" class="container">
                  <RightNavButtons>
                      <Button systemButton="Ti.UI.iPhone.SystemButton.ADD" onClick="doClick"/>
                  </RightNavButtons>
             </Window>
          </NavigationWindow>
      </Alloy>
      

      Please note that there is no issue when using this format, only the "RightNavButton" as opposed to "RightNavButtons"

      <Alloy>
          <NavigationWindow id="nav" formFactor="handheld">
              <Window id="win" class="container">
                   <RightNavButton title="ADD" onClick="doClick" systemButton="ADD"/>
              </Window>
          </NavigationWindow>
      </Alloy>
      

      This seems that it worked fine in 3.4.1

      source code available here https://gist.github.com/aaronksaunders/04caa6b1b2443e87430c

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                rtlechuga Radamantis Torres-Lechuga (Inactive)
                Reporter:
                aaron@clearlyinnovative.com Aaron K. Saunders
              • Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Git Source Code