Uploaded image for project: 'Appcelerator - INBOX'
  1. Appcelerator - INBOX
  2. AC-1296

Ti Studio doesn't recognize ti cli, acs and alloy installation made it by nvm

    Details

    • Type: Bug
    • Status: Closed
    • Resolution: Invalid
    • Affects Version/s: None
    • Component/s: Alloy, Appcelerator CLI, Studio
    • Environment:

      Ubuntu 14.04 x64
      nvm version: 0.10.0
      nvm installation path: $HOME/.nvm/v0.10.29/bin (it's included in PATH by nvm)
      Titanium Studio version: 3.3.0.201407100905

      Description

      I change my defualt nodejs installation 'cause I need to use other commads without sudo. I change it using nvm.

      I reinstall Ti Studio, also added nvm and bins to PATH variable. Install titanium, alloy and acs from Ti Studio terminal, and nothing...

      Every time I try to open Studio ask me to install Ti CLI, Alloy and ACS, when I try to install by Ti Studio, throw me an error that doesn't find npm.

      Do anybody has an idea of how to fix this?. Thanks.

        Attachments

          Activity

            People

            • Assignee:
              mpmiranda Mauro Parra-Miranda
              Reporter:
              arandilopez Arandi López
            • Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Backbone Issue Sync

                • It looks like Backbone Issue Sync is not enabled for your project.

                  Git Source Code